install sous gentoo

Page 2 sur 3 Précédent  1, 2, 3  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Re: install sous gentoo

Message  pascal50 le Mer 20 Aoû - 22:31

Bonsoir,
1) J'ai converti les fichiers sources en utf-8 avec iconv
2) Dans Projet > Options du compilateur > Autre >
j'ai changé l'opton -Fc8859-1 en -Fcutf8

La complation s'est bien effectuée. J'ai enfin les bons caractères dans les menus.

Une chose me tracasse : j'ai vu dans le code, mais je ne me rapelle plus où, des définitions de polices en iso8859-1.

Une autre : comment fermer lazarus correctement : car il réouvre automatiquement le projet quand je le relance, en me demandant parfois de sauvegarder et c'est un peu déroutant.

MODIF :
J'ai encore des carrés avec diagonales dans Créer > Aures élément graphiques 2D. Grrrr ...

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Mer 20 Aoû - 22:44

Code:

$ grep -n 'iso' *
Apropos.lfm:18:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-p-*-iso8859-1'
Apropos.lrs:10:  +'vetica-medium-r-normal-*-12-*-*-*-p-*-iso8859-1'#10'Font.Pitch'#7#10'fpVari'
Attributs.lfm:16:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
Attributs.lrs:9:  +#12#9'Font.Name'#6'9-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-'
AxesGrille.lfm:16:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
AxesGrille.lrs:9:  +#12#9'Font.Name'#6'9-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-'
Editeur.lfm:18:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
Editeur.lfm:123:    Font.Name = '-adobe-courier-medium-r-normal-*-*-*-*-*-*-*-iso10646-1'
Editeur.lrs:10:  +'dobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'#10'Font.Pitch'#7#10
Editeur.lrs:43:  +'nt.Name'#6'7-adobe-courier-medium-r-normal-*-*-*-*-*-*-*-iso10646-1'#11'Par'
Fenetre.lfm:16:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
Fenetre.lrs:9:  +#2#12#9'Font.Name'#6'9-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso885'
graph1_6.pas:1806:                writeln(f,'<?xml version="1.0" encoding="iso-8859-15" standalone="no"?>');
Input.lfm:15:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
Input.lrs:9:  +'r-normal-*-12-*-*-*-*-*-iso8859-1'#10'Font.Pitch'#7#10'fpVariable'#8'Positi'
Marges.lfm:15:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
Marges.lrs:9:  +'nt.Name'#6'9-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'#10'F'
Parametree.lfm:15:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
Parametree.lrs:9:  +'ame'#6'9-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'#10'Font.'
PressePap.lfm:16:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
PressePap.lrs:10:  +'12-*-*-*-*-*-iso8859-1'#10'Font.Pitch'#7#10'fpVariable'#8'Position'#7#16'po'
SimpleGraph.lfm:19:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
SimpleGraph.lrs:11:  +'al-*-12-*-*-*-*-*-iso8859-1'#10'Font.Pitch'#7#10'fpVariable'#8'OnCreate'#7
Unit1.lfm:15:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
Unit1.lrs:9:  +'a-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'#10'Font.Pitch'#7#10'fpVariable'
Varglobs.lfm:16:  Font.Name = '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-iso8859-1'
Varglobs.lrs:10:  +'-iso8859-1'#10'Font.Pitch'#7#10'fpVariable'#8'OnCreate'#7#10'FormCreate'#8

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Mer 20 Aoû - 23:03

Bonsoir Pascal,

En fait il n'y a que deux ou trois endroits dans le source où il y a réellement une modif à faire pour l'encodage des caractères car j'ai fait en sorte que toutes les fenêtres héritent de la même fonte lors de leur création, cela ne sert donc à rien de modifier les fichiers *.lfm et *.lrs Laughing .

Pour l'autre problème c'est qu'il faut aussi convertir en utf8 tout le contenu du dossier macros (qui contient les fichiers *.mac et *.mod) ainsi que les fichiers du dossier Exemples.

Je fais ça tout à l'heure quand j'aurai un moment, et je poste un zip contenant tout ça comme il faut Wink .

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Jeu 21 Aoû - 2:11

Voilà, il m'a fallu un peu de temps...
Je poste l'archive TeXgraph1.94Utf8.tar.gz. (Lien mort)

Tu peux la décompresser dans ton home, je n'ai pas mis la doc mais tout le reste est converti en utf8, il y a le dossier TeXgraph qui contient les dossiers: Exemples, macros et src, ainsi que l'exécutable TeXgraph en gtk2. Un double-clic doit permettre de le lancer pour tester. Bien sûr il y a aussi les sources qui ont donné cet exécutable.


Dernière édition par P.Fradin le Lun 25 Aoû - 16:10, édité 1 fois

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Ven 22 Aoû - 22:20

Bonsoir,
J'ai

  • deplier les sources
  • changer le chemin vers ExecutableGUI
  • Recompiler
J'ai écrasé l'ancien exécutable par le nouveau.

J'ai bien les accents dans les menus sauf dans cette fenêtre :


Quand je lance TexGraph, j'ai aussi 2 fenêtres d'erreur :
Macro MapBy : un argument est vide
[/usr/local/share/TeXgraph/macros/Texgraph.mac] ligne 3 : un argument est vide

Cela n'a pas l'air d'être bloquant.

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Ven 22 Aoû - 22:32

pascal50 a écrit:Bonsoir,

Bonsoir Pascal,

J'ai écrasé l'ancien exécutable par le nouveau.

Cela ne suffit pas, il faut aussi écraser l'ancien dossier macros par le nouveau (qui est en utf8, mais pas l'ancien)

PS: sous ton implusion j'ai passé tout le projet TeXgraph en utf8 et gtk2, je poste une archive linux complète ce soir ou demain.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Sam 23 Aoû - 0:04

P.Fradin a écrit:
il faut aussi écraser l'ancien dossier macros

C'est fait. Et en effet cela marche beaucoup mieux. Merci.

Je vais pouvoir me consacrer à l'utilisation de TeXgraph Wink .

J'utilise actuellement open office Impress pour mes cours (j'enseigne en lycée professionnel). Je découvrre Latex et Beamer.
Je désire des choses simples, mais les animations sont assez complexes.

La difficulté pour moi c'est d'intégrer tous ces outils ! Je ne sait pas si je serais gagnant au bout du compte. Cela fait quand même beaucoup de code à apprendre... Mais l'ensemble est plus cohérent.

Un essai d'intégration dans mon modèle de document (graphique exporté depuis Géogébra en pstricks) : cours08.pdf
Un second (graphique exporté depuis TeXgraph), pour vérifier la mise à l'échelle et l'animation du graphique (\onslide) : cours00.pdf

J'ai cru comprendre que tu utilise TeXgraph tel quel en cours : lien

J'ai aussi vu que l'on pouvait faire des animations en flash : lien . As tu testé sous linux (élaboration - visualisation) ?

Enfin une dernière requète : je n'ai pas trouvé de logiciel pour représenter les séries statistiques. J'ai essayé WxGéométrie, mais il est trop bugué sous linux.

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Sam 23 Aoû - 2:03

Bonsoir Pascal,

Ravi que cela marche mieux!
Pour faire des animations beamer avec TeXgraph tu peux insérer les instructions \pause directement dans Texgraph sans avoir à bircoler le fichier exporté, comme le montre cet exemple:

le fichier source: beamer.teg

a été exporté en beamer.tkz, puis inclus dans un document latex:

Code:

\documentclass[11pt]{beamer}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage{beamerarticle}
\usepackage{color,texgraph,tikz}

\usetheme{Warsaw}
\usecolortheme{crane}


\begin{document}

\begin{frame}[fragile]
\frametitle{TeXgraph et Beamer : petit exemple}
\begin{columns}[c]
 \begin{column}{7cm}
\input{beamer.tkz}
\end{column}
\onslide<1->{
\begin{column}{5cm}
 \begin{enumerate}
 \item<1-> Tracé du repère
 \item<2-> Tracé de la courbe
 \item<3-> Tracé du point
 \item<4-> Tracé de la tangente
\end{enumerate}
\end{column}}
\end{columns}
\end{frame}

\end{document}

Ce qui donne le fichier beamer.pdf.

Tu verras dans le source comment ont été introduite les pauses, grace à l'instruction Special qui écrit directement dans le fichier exporté. Cette technique est une idée de Samuel Biton qui vient nous voir de temps à autre.

PS1: pour les animations flash, on peut les faire sous linux comme sous windows.

PS2: pour les séries statistiques j'avais commencé un fichier il y a bien longtemps, il faudrait que je remette la main dessus.

PS3: je teste la version gtk2, l'aspect esthétique est agréable, mais ce n'est pas sans soucis, j'ai déjà du signaler un bug à l'équipe qui maintient lazarus et je viens de m'apercevoir que pour la 3D il y a parfois des problèmes de violation alors qu'il n'y en avait pas en gtk1 (ni sous windows)...

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Sam 23 Aoû - 19:02

En effet cela a l'air plus simple !

P.Fradin a écrit:
... a été exporté en beamer.tkz
Je suppose que c'est en utilisant la commande "Exporter en Tikz" ?

Une question ! TeXgraph n'est pas prévu pour l'internationalisation ?

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Sam 23 Aoû - 21:20

pascal50 a écrit:En effet cela a l'air plus simple !


Je suppose que c'est en utilisant la commande "Exporter en Tikz" ?

Oui, mais j'ai l'habitude de ne mettre que 3 lettres aux extensions (comme pst pour pstricks) Smile


Une question ! TeXgraph n'est pas prévu pour l'internationalisation ?


Ce n'est pas prévu, et il y aurait un sacré boulot! Ceci dit au départ il n'était pas prévu non plus que TeXgraph sorte de ma machine...

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  Joffrey le Dim 24 Aoû - 20:12

Bonsoir,

Juste pour faire une petite remarque :
P.Fradin a écrit:
Ceci dit au départ il n'était pas prévu non plus que TeXgraph sorte de ma machine...
Ca aurait quand même été très dommage!!!!

Allez bonne soirée

Joffrey

Joffrey

Nombre de messages : 179
Age : 35
Localisation : Vichy(03) / Clermont-Ferrand(63)
Date d'inscription : 13/06/2008

Voir le profil de l'utilisateur http://mathex.servhome.org

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Dim 24 Aoû - 21:31

Bonsoir,
Je poste ce message, car j'ai un soucis sur mon portable, alors que je ne l'ai pas sur mon pc fixe. Tous les 2 sous gentoo.
J'ai cette erreur avec ce fichier animation.teg.
Elle est déclenchée lors de la sauvegarde.
Sur le pc fixe (qui n'a pas ce problème), le fichier fourier.sty n'existe pas non plus. Je ne comprends pas pourquoi il est nécessaire sur le portable.
Mes recherches sur le net sont maigres !


$ startTeXgraph
TGtk2WSCustomListBox.SetBorder TODO
TGtk2WSCustomListBox.SetBorder TODO
TGtk2WSCustomListBox.SetBorder TODO
This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
%&-line parsing enabled.
entering extended mode
(./CompilePdf.tex
LaTeX2e <2005/12/01>
Babel <v3.8h> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, basque, french, loaded.
(/usr/share/texmf-dist/tex/latex/base/article.cls
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
(/usr/share/texmf-dist/tex/latex/base/size11.clo))
(/usr/share/texmf-dist/tex/latex/base/inputenc.sty
(/usr/share/texmf-dist/tex/latex/base/latin1.def))
(/usr/share/texmf-dist/tex/latex/base/fontenc.sty
(/usr/share/texmf-dist/tex/latex/base/t1enc.def))

! LaTeX Error: File `fourier.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name:
! Emergency stop.
<read *>

l.5 \usepackage
{pgf,amssymb,amsmath,amsfonts,babel}^^M
! ==> Fatal error occurred, no output PDF file produced!
Transcript written on CompilePdf.log.
cp: ne peut évaluer `CompilePdf.pdf': Aucun fichier ou répertoire de ce type

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Dim 24 Aoû - 21:53

Bonsoir pascal,

C'est curieux en effet. Je vois un latin1.def qui traine alors que maintenant tout est en utf8, cela est dû aux scripts qui générent les images epsc et pdfc qui ne sont pas encore adaptés, mais si cela venait de là tu devrais avoir aussi le même problème sur le pc.
Que donne le fichier log si tu compiles le même fichier sur ton fixe?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Dim 24 Aoû - 22:22

Je suppose que tu désignes ~/.TeXgraph/CompilePdf.log :
Le voici : 01_CompilePdf.log

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Dim 24 Aoû - 22:39

C'est curieux, c'est la même version de pdftex mais les fichiers log ne sont pas identiques! C'est la même distribution exactement?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Dim 24 Aoû - 23:03

P.Fradin a écrit:C'est la même distribution exactement?

Le problème est là ! Je cherche ce qui fait la différence entre les 2. Je soupçonne un paquet ou un use que j'aurai oublié.
Quelque chose "remplit" la fonctionnalité "fourier.sty" sur le pc fixe. D'après ce que je peux comprendre, c'est lié à des polices propriétaires adobe. Mais je peux me tromper.

Pour l'installation de TexGraph sur le portable, j'ai :
  • installé lazarus
  • copié les répertoires TeXgraph 1.93 et 1.94 du PC fixe dans le portable
  • copié le répertoire doc de la version 1.93 dans la 1.94
  • installé en root la 1.94
  • recompilé les sources de la 1.94
  • écrasé l'executable installé avec le compilé.

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Dim 24 Aoû - 23:12

D'après moi cela vient de la différence entre les deux installations TeX car TeXgraph génére le même fichier sur les deux machines, tout vient donc de la compilation TeX. Si tu regardes bien les deux log, avant l'erreur, ils ne sont pas identiques!

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Lun 25 Aoû - 0:23

P.Fradin a écrit:
Si tu regardes bien les deux log, avant l'erreur, ils ne sont pas identiques!
Attention :
sur le PC fixe j'ai bien un fichier log.
mais sur le portable, c'était la sortie console dans laquelle est lancé TeXgraph et non pas le fichier log !
Je remets donc 2 liens :
log pc fixe : CompilePdf.log
log portable : CompilePdf.log

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Lun 25 Aoû - 0:32

Oui tu as raison!

Sur ton fixe, le package lmodern.sty est chargé et au même endroit sur ton portable c'est fourier.sty qui chargé!! As-tu lmodern.sty sur ton portable?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Lun 25 Aoû - 0:49

Les 2 fichiers sty sont présents :
Code:

portable portage # ls -l /usr/share/texmf-dist/tex/latex/lm/lmodern.sty
-rw-r--r-- 1 root root 1346 aoû  9 09:33 /usr/share/texmf-dist/tex/latex/lm/lmodern.sty

Code:

poste02 portage # ls -l /usr/share/texmf-dist/tex/latex/lm/lmodern.sty
-rw-r--r-- 1 root root 1346 aoû  7 01:45 /usr/share/texmf-dist/tex/latex/lm/lmodern.sty

Ces 2 fichiers appartiennent au paquet dev-texlive/texlive-basic-2007. Il est à la même version sur les 2 postes.

J'ai recherché ceci sur le pc fixe, sans résultat :
Code:

find /usr -type f | xargs grep -n '\\ProvidesPackage{fourier}'

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Lun 25 Aoû - 1:01

Et si tu compiles ça sur ton portable, que dit le fichier log?

Code:

\documentclass{article}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}

\begin{document}
 
Ceci est un test
\end{document}

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Lun 25 Aoû - 1:29

Finalement j'ai désinstallé TeXgraph, et j'ai repris la même procédure de l'installation du pc fixe et le problème a disparu.

J'ai :
  • installé en root la 1.93 (au lieu de la 1.94)
  • refait le lien libgdk_pixbuf
  • écrasé l'exécutable par celui compilé (1.94)
  • écrasé les macros installées par celles de la 1.94

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Lun 25 Aoû - 1:39

pascal50 a écrit:Finalement j'ai désinstallé TeXgraph, et j'ai repris la même procédure de l'installation du pc fixe et le problème a disparu.

J'ai :
  • installé en root la 1.93 (au lieu de la 1.94)
  • refait le lien libgdk_pixbuf
  • écrasé l'exécutable par celui compilé (1.94)
  • écrasé les macros installées par celles de la 1.94

Ca alors! C'est curieux! Je ne m'explique pas comment l'install de TeXgraph a influé sur la compilation, sauf si les deux fichiers CompilePdf.tex produits ne sont pas rigoureusement les mêmes!
Si tu connais le fin de l'histoire, cela m'intéresse de comprendre!

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  pascal50 le Lun 25 Aoû - 1:53

Je n'ai pas recompilé entre la précédente installation et la nouvelle.
J'ai juste écrasé l'exécutable installé (1.93) par celui déjà fait dans ExecutableGUI(1.94).
La seule différence, c'est que j'ai lancé le script install.sh 1.93 au lieu du 1.94, refait le lien libgdk_pixbuf, ecrasé l'exécutable, puis les macros.

Je tenais vraiment à avoir TeXgraph fonctionnel , pour pouvoir bosser dessus au lycée !

J'ai un autre soucis avec l'exportation pdf d'un document (sur les 2 PC Wink ), mais on verra demain ...

Faut-il faire un autre fil ?

pascal50

Nombre de messages : 30
Age : 58
Date d'inscription : 16/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: install sous gentoo

Message  P.Fradin le Lun 25 Aoû - 1:58

pascal50 a écrit:Je n'ai pas recompilé entre la précédente installation et la nouvelle.
J'ai juste écrasé l'exécutable installé (1.93) par celui déjà fait dans ExecutableGUI(1.94).
La seule différence, c'est que j'ai lancé le script install.sh 1.93 au lieu du 1.94, refait le lien libgdk_pixbuf, ecrasé l'exécutable, puis les macros.

Je tenais vraiment à avoir TeXgraph fonctionnel , pour pouvoir bosser dessus au lycée !

J'ai un autre soucis avec l'exportation pdf d'un document (sur les 2 PC Wink ), mais on verra demain ...

Faut-il faire un autre fil ?

Pas la peine de commencer un autre fil. J'ai fait à peu près le tour de mes tests en GTK2 et je posterai une version complète demain, les problèmes rencontrés sont réglès et cela a pris du temps (mais il y en aura peut-être d'autres!). On continuera sur ce fil.

Bonne nuit!

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: install sous gentoo

Message  Contenu sponsorisé Aujourd'hui à 11:53


Contenu sponsorisé


Revenir en haut Aller en bas

Page 2 sur 3 Précédent  1, 2, 3  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum