[Résolu] Animation

Page 2 sur 3 Précédent  1, 2, 3  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 2:53

J'ai installé les outils swftools, et cela fonctionne. En effet, j'avais écrit une animation avec asymptote Embarassed que j'ai enregistrée dans un fichier _exemple.pdf, puis que j'ai convertie en _exemple.swf avec la commande pdf2swf _exemple.pdf
Je peux lire sans problèmes ce fichier avec Firefox.
Je crois qu'il y a encore un problème !
Après avoir enregistré l'animation essai1.teg (mon animation corrigée par tes soins), TeXgraph me dit que les 50 frames vont être compilées dans un fichier pdf dans le répertoire /home/fab/essai1.
Je clicke sur OK, et sans fermer TeXgraph, je vais voir si ce fichier existe et ........ Sad
Lorsque je clicke ensuite sur Flash, seul un fichier essai1.html est créé, et il est vide (ce qui paraît logique puisque le fichier essai1.pdf semble ne pas avoir été crée !)

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 11:11

D'où ma question d'hier soir: est-ce que l'aperçu fonctionne?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 12:22

Bonjour Patrick,
Bien dormi ! Very Happy
L'aperçu fonctionne :
1. xpdf s'ouvre avec ce que j'ai demandé (ligne polygonale) ;
2. création de 3 fichiers dans .TeXgraph : apercu.log, apercu.pdf et file.pgf.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 12:27

Salut Fabrice,

Très bien dormi!

Lance TeXgraph, dessine par exemple des axes, et exporte en pdf compilé avec le menu: Fichier/Exporter en pdf compilé, enregistre-le dans /home/fab sous le nom test.pdf. Vérifie ensuite qu'il y a bien test.pdf dans /home/fab/

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 13:01

Ce fichier n'existe pas.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 13:15

Ok, recommence la manip (exporter en pdf compilé dans /home/fab/test.pdf) et sans fermer TeXgraph regarde dans le dossier .TeXgraph il doit y avoir CompilePdf.log et CompilePdf.pdf. Si c'est le cas, que dit le fichier log?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 14:31

Il y a bien un fichier CompilePdf.log mais pas de fichier CompilePdf.pdf.
Je joins une partie de ce fichier :
! Package inputenc Error: Keyboard character used is undefined
(inputenc) in inputencoding `latin1'.

See the inputenc package documentation for explanation.
Type H <return> for immediate help.
...

l.9 ^^H
egin{document}
You need to provide a definition with \DeclareInputText
or \DeclareInputMath before using this key.


! LaTeX Error: Missing \begin{document}.

See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...

l.9 ^^He
gin{document}
You're in trouble here. Try typing <return> to proceed.
If that doesn't work, type X <return> to quit.


! LaTeX Error: Missing \begin{document}.

See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...

l.11 e
wcounter{compt}
You're in trouble here. Try typing <return> to proceed.
If that doesn't work, type X <return> to quit.


! LaTeX Error: No counter 'compt' defined.

See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...

l.12 \setcounter{compt}{1}

Your command was ignored.
Type I <command> <return> to replace it with another command,
or <return> to continue without it.

)
Runaway argument?
^^Hegin{preview} \input {frame hecompt.pgf}\end {preview} \ifnum heco\ETC.
! File ended while scanning use of \loop.
<inserted text>
\par
<*> CompilePdf.tex

I suspect you have forgotten a `}', causing me
to read past where you wanted me to stop.
I'll try to recover; but if the error is serious,
you'd better type `E' or `X' now and fix your file.

! Emergency stop.
<*> CompilePdf.tex

*** (job aborted, no legal \end found)


Here is how much of TeX's memory you used:
8345 strings out of 93923
127892 string characters out of 1161625
177706 words of memory out of 1500000
11471 multiletter control sequences out of 10000+50000
4709 words of font info for 16 fonts, out of 1200000 for 2000
759 hyphenation exceptions out of 8191
39i,0n,39p,396b,53s stack positions out of 5000i,500n,6000p,200000b,5000s
! ==> Fatal error occurred, no output PDF file produced!

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 15:10

Arf! encore un coup de l'utf8 je parie.

Bon, avec ton éditeur habituel, charge le fichier CompilePdf.tex, change latin1 en utf8, et essaye de compiler, dis moi si ça passe.

Ce qui est curieux c'est qu'il n'y a pas de problème pour l'aperçu alors qu'il utilise aussi latin1!!!!

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 15:43

Cela ne fonctionne toujours pas. Je joins le fichier CompilePdf.tex qui semble comporter des anomalies :

\documentclass[11pt,frenchb]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{pgf,amssymb,amsmath,amsfonts,babel}
\usepackage[a4paper,margin=0cm,pdftex]{geometry}
\usepackage[active,tightpage]{preview}
\pagestyle{empty}
egin{document}

ewcounter{compt}
\setcounter{compt}{1}
\loop
egin{preview}
\input{frame hecompt.pgf}%
\end{preview}
\ifnum hecompt<1ddtocounter{compt}{1}

epeat
\end{document}

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 15:50

Tu l'as ouvert en utf8 ou latin1 ce fichier? Car il manque des caractères, il faut l'ouvrir en latin1 si ton éditeur le permet!

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 15:57

J'ai utilisé KIle, mais je ne trouve pas latin 1 dans tools -> encoding ( il est coché sur utf8)

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 16:03

Tu prends iso 8859-15

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 16:16

Rien n'y fait, il manque toujours des lettres.
J'ai ouvert ce fichier avec un simple éditeur de texte (gedit), et il manque aussi des lettres. Je n'ai jamais eu ce type de problème avec d'autres fichiers.
Ps : Je dois m'absenter, à tout de suite Very Happy

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 16:28

Pourtant je peux t'assurer que le fichier d'origine est correct!
C'est un problème d'encodage de caractères.
D'ailleurs tu peux lire le fichier d'origine: dans /usr/local/share/TeXgraph/ ouvre le script CompilePdf.sh avec un éditeur de texte, c'est lui qui génère CompilePdf.tex.

Je demande à Samuel s'il a eu le même problème sous Ubuntu.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mer 20 Fév - 21:10

Bonjour,

J'ai eu la réponse de Samuel, il a bien eu le même problème, celui-ci vient du fait que dans le script CompilePdf.sh les antislash sont interprétés par sh lors de l'exécution de la commande echo. Pour contourner ce problème on peut mettre bash à la placed de sh dans le script comme ceci:

Code:

#!/bin/bash
echo "\documentclass[11pt,frenchb]{article}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{pgf,amssymb,amsmath,amsfonts,babel}
\usepackage[a4paper,margin=0cm,pdftex]{geometry}
\usepackage[active,tightpage]{preview}
\pagestyle{empty}
\begin{document}
\newcounter{compt}
\setcounter{compt}{1}
\loop
\begin{preview}
\input{frame\thecompt.pgf}%
\end{preview}
\ifnum \thecompt<"$1"\addtocounter{compt}{1}
\repeat
\end{document}" > CompilePdf.tex

pdflatex -interaction=nonstopmode CompilePdf.tex
cp -f CompilePdf.pdf $2.pdf

Donc tu te connectes en root, tu édites le script CompilePdf.sh (qui est dans /usr/local/share/TeXgraph), tu remplaces son contenu par celui-ci et tu sauves. Voilà qui devrait résoudre le problème. Tiens nous au courant!

PS: je ne m'étais jamais rendu de ce problème car sur ma machine les antislash ne sont pas interprétés par sh! Je dis donc: merci Samuel! Very Happy

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  samuel.biton le Mer 20 Fév - 21:48

Bonsoir Patrick et F,

petit correctif car j'ai commis une coquille dans le mail que j'ai envoyé à Patrick Embarassed !

Vérification faite, sur ma ubuntu si on fait


Code:

#!/bin/sh
echo 'coucou \\begin{document}coucou' > ./essai.tex

avec bien ' comme quote et pas ", le doublement du \ permet d'éviter la transformation du "\b" (et du \r par exemple) par sh.

Par contre l'autre truc qui fonctionne est :

Code:

#!/bin/bash
echo "coucou \begin{document}coucou" > ./essai.tex

Du coup dans le script CompilePdf.sh on met #!/bin/bash il faudrait savoir si cela fonctionne pour toutes les distributions.

Samuel

samuel.biton

Nombre de messages : 25
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mer 20 Fév - 21:55

Et donc ceci:

Code:

echo "\\begin..."

ne marche pas chez toi?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  samuel.biton le Mer 20 Fév - 22:19

Salut Patrick,

non justement pas avec "" : mais avec '
#!/bin/sh
echo '\\begin{document}' > essai.tex


par contre cela fonctionne (les ' ' font que le premier \ doit être interpréter comme un caractère d'échappement, donc du coup le suivant le \b qui suit n'est pas interprété. Mais il nous faudrait l'avis
d'un plus spécialiste que moi sur le bash....


Par contre : #!/bin/bash
fonctionne-il aussi sous mandriva?


Samuel

samuel.biton

Nombre de messages : 25
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mer 20 Fév - 23:12

samuel.biton a écrit:
non justement pas avec "" : mais avec '
#!/bin/sh
echo '\\begin{document}' > essai.tex

par contre cela fonctionne (les ' ' font que le premier \ doit être interpréter comme un caractère d'échappement, donc du coup le suivant le \b qui suit n'est pas interprété. Mais il nous faudrait l'avis
d'un plus spécialiste que moi sur le bash....


Par contre : #!/bin/bash
fonctionne-il aussi sous mandriva?

Et bien chez moi les quotes ne fonctionnent pas Sad , mais par contre les " et \\ fonctionnent...
Le coup du #!/bin/bash au lieu de #!/bin/sh, fonctionne aussi en conservant le texte d'origine (c'est à dire les " et \, on est bien d'accord?).

Je pense que je vais opter pour cette dernière solution.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Jeu 21 Fév - 3:12

Bonsoir,
Après avoir modifié le fichier CompilePdf.sh comme tu l'indiquais :
Code:
#!/bin/bash
echo "\documentclass[11pt,frenchb]{article}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{pgf,amssymb,amsmath,amsfonts,babel}
\usepackage[a4paper,margin=0cm,pdftex]{geometry}
\usepackage[active,tightpage]{preview}
\pagestyle{empty}
\begin{document}
\newcounter{compt}
\setcounter{compt}{1}
\loop
\begin{preview}
\input{frame\thecompt.pgf}%
\end{preview}
\ifnum \thecompt<"$1"\addtocounter{compt}{1}
\repeat
\end{document}" > CompilePdf.tex

pdflatex -interaction=nonstopmode CompilePdf.tex
cp -f CompilePdf.pdf $2.pdf
Lance TeXgraph, dessine par exemple des axes, et exporte en pdf compilé avec le menu: Fichier/Exporter en pdf compilé, enregistre-le dans /home/fab sous le nom test.pdf. Vérifie ensuite qu'il y a bien test.pdf dans /home/fab.
Eh bien, TeXgraph se ferme automatiquement et aucun fichier test.pdf n'est créé !!!

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Jeu 21 Fév - 11:06

Bizarre, cela fonctionne chez Samuel qui est lui aussi sous Ubuntu... D'autant plus curieux que tous les scripts à l'installation ont été créés avec cette méthode et ils ne semblent pas avoir posé de problèmes!

Bon, dernière proposition (qui fonctionne aussi sous Ubuntu):

Remplacer le contenu de CompilePdf.sh (/usr/local/share/TeXgraph en root, bien s'assurer que le script est exécutable en regardant les propriétés!! cela peut-être le problème que tu as rencontré) par celui-ci:

Code:

#!/bin/sh
cat > CompilePdf.tex <<EOF
\documentclass[11pt,frenchb]{article}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{pgf,amssymb,amsmath,amsfonts,babel}
\usepackage[a4paper,margin=0cm,pdftex]{geometry}
\usepackage[active,tightpage]{preview}
\pagestyle{empty}
\begin{document}
\newcounter{compt}
\setcounter{compt}{1}
\loop
\begin{preview}
\input{frame\thecompt.pgf}%
\end{preview}
\ifnum \thecompt<$1\addtocounter{compt}{1}
\repeat
\end{document}
EOF

pdflatex -interaction=nonstopmode CompilePdf.tex
cp -f CompilePdf.pdf $2.pdf

PS: je viens de vérifier, quand on lance un script non exécutable cela fait planter le programme (ce qui n'est pas étonnant). Donc tu as peut-être recréé un script CompilePdf.sh mais qui n'était pas exécutable.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  samuel.biton le Jeu 21 Fév - 11:52

Bonjour F,


Eh bien, TeXgraph se ferme automatiquement et aucun fichier test.pdf n'est créé !!!

Si après avoir rendu éxécutable le fichier comme le dit Patrick, cela ne fonctionne toujours pas,
peux-tu recopier l'éxécutable CompilePdf.sh en commentant les deux dernières lignes

Code:

pdflatex -interaction=nonstopmode CompilePdf.tex
cp -f CompilePdf.pdf $2.pdf

Le rendre éxécutable par

Code:

chmod +x CompilePdf.sh

Puis l'éxécuter en ligne de commande (sans TeXgraph en fait) pour avoir le résultat. Normalement, un fichier CompilePdf.tex devrait se créer avec le bon code dedans.





Samuel

samuel.biton

Nombre de messages : 25
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Jeu 21 Fév - 14:18

Bonjour Samuel et Patrick,
Comme je l'ai dit à Patrick, je suis nouveau sous linux, et il est probable que des procédures m'échappent.
Je résume :
Remplacer le contenu de CompilePdf.sh (/usr/local/share/TeXgraph en root, bien s'assurer que le script est exécutable en regardant les propriétés!! cela peut-être le problème que tu as rencontré) par celui-ci:
Je joins ma procédure :
fab@fab-desktop:~$ sudo su
root@fab-desktop:/home/fab# cd /usr/local/share/TeXgraph
root@fab-desktop:/usr/local/share/TeXgraph# gedit CompilePdf.sh

(gedit:6101): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
root@fab-desktop:/usr/local/share/TeXgraph#
Le fichier s'ouvre, je le remplace par celui que tu as joint, puis j'enregistre.
Je ne suis pas le propriétaire de ce fichier qui a bien été modifié (root), et là je suis un peu perdu !!!
Fabrice Couvreur.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Jeu 21 Fév - 14:26

Salut Fabrice,

Dans une console: tu te connectes en root, tu lances ton gestionnaire de fichiers en root (konqueror?), tu vas dans /usr/local/share/TeXgraph, tu fais un cliques droit sur le fichier CompilePdf.sh et dans l'onglet propriétés tu regardes si l'option exécutable est cochée (probablement non), il faut la cocher.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Jeu 21 Fév - 16:30

Salut,
Je viens de découvrir Konqueror que je n'utilisais pas (comme d'ailleurs aucun gestionnaires de fichiers).
Je joins le contenu du fichier CompilePdf.sh
Code:
#!/bin/sh
cat > CompilePdf.tex <<EOF
\documentclass[11pt,frenchb]{article}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{pgf,amssymb,amsmath,amsfonts,babel}
\usepackage[a4paper,margin=0cm,pdftex]{geometry}
\usepackage[active,tightpage]{preview}
\pagestyle{empty}
\begin{document}
\newcounter{compt}
\setcounter{compt}{1}
\loop
\begin{preview}
\input{frame\thecompt.pgf}%
\end{preview}
\ifnum \thecompt<$1\addtocounter{compt}{1}
\repeat
\end{document}
EOF

pdflatex -interaction=nonstopmode CompilePdf.tex
cp -f CompilePdf.pdf $2.pdf
Je joins aussi une image pour te montrer que l'option exécutable est bien cochée (ce que j'avais déjà vérifiée Very Happy ! )
Rien n'y fait : quand j'exporte avec Pdf compilé, aucun fichier test.pdf et TeXgraph se ferme !

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  Contenu sponsorisé Aujourd'hui à 11:53


Contenu sponsorisé


Revenir en haut Aller en bas

Page 2 sur 3 Précédent  1, 2, 3  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum