[Résolu] Animation

Page 1 sur 3 1, 2, 3  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

[Résolu] Animation

Message  F.Couvreur le Dim 17 Fév - 13:26

Bonjour Patrick,
J' essaye d'écrire ma première animation :
Code:
% TeXgraph version 1.93

% Fenetre Xmin Xmax Ymin Ymax Xscale Yscale

100#-0.806532663317#10.193467336683#-0.027586206897#11.972413793103#1#1##

% Marges gauche droite haut bas cadre gestion_couleur comptgraph

101#0.5#0.5#0.5#0.5#0#1#32##

% Affectation des Variables theta et phi

18##[theta:=0.5236, phi:=1.0472, OriginalCoord(1)]##

18##InputMac("Animation.mac")##

% Déclaration des Variables Globales

15#alpha#2.4##

% Déclaration des Macros

16#MakeFrame#[{code pour dessiner la frame n° %1}
  alpha := %1*4/25, ReCalc(M, trajectoire, trajectoire1,trajectoire2,N, P
  ,AMNP,S,trajectoire3)


]
##

16#OnBeginAnim#[{exécutée au lancement de l'animation}



]##

16#OnEndAnim#[{exécutée à la fin de l'animation}



]##

16#Initialiser#[{valeurs par défaut de vos paramètres}
  alpha :=0, ReCalc(M, trajectoire, trajectoire1,trajectoire2, N, P,AMNP,
  S,trajectoire3)


]
##

16#Tempo#100##

16#NbFrames#50
##

16#Nom#"/home/fab/.TeXgraph/"##

16#PdfReader#"xpdf"##

% Déclaration des Eléments graphiques

% trajectoire1 (Utilisateur)

18##[Width:=4,Color:=255,LineStyle:=-1,tMin:=-1,tMax:=10]##

14#trajectoire1#Dparallel([8,8+10*i],alpha)
#-1##

% trajectoire (Ligne Polyg.)

18##[LineStyle:=0]##

12#trajectoire#[alpha  ]#0#0##

% M (Point(s))

4#M#[alpha  ]##

% angleD9 (Utilisateur)

18##[Width:=2,Color:=0,FillStyle:=1]##

14#angleD9#angleD(0,8,8+10*i,0.3)
#-1##

% segment1 (Ligne Polyg.)

18##[Width:=4,FillStyle:=0]##

12#segment1#[0,8+10*i  ]#0#0##

% N (Utilisateur)

18##[Color:=255]##

14#N#Point(Intersec(trajectoire1,segment1))
#-1##

% trajectoire2 (Utilisateur)

18##[Color:=0,LineStyle:=-1]##

14#trajectoire2#Dparallel([0,alpha],Intersec(trajectoire1,segment1))
#-1##

% segment2 (Ligne Polyg.)

18##[Width:=2,LineStyle:=0]##

12#segment2#[8,8+10*i  ]#0#0##

% triangle (Ligne Polyg.)

18##[Width:=8]##

12#triangle#[ 0,8,8+10*i ,0]#0#0##

% P (Utilisateur)

18##[Width:=4,Color:=255]##

14#P#Point(Intersec(trajectoire2,segment2))
#-1##

% AMNP (Utilisateur)

18##[Color:=0,FillStyle:=1,FillColor:=255]##

14#AMNP#Drectangle(alpha,8,Intersec(trajectoire1,segment1),FillStyle:=full)
#-1##

% S (Point(s))

18##[Color:=255]##

4#S#[abs(alpha )+i*0.5*abs(Intersec(trajectoire1,segment1)-alpha)*abs(8-alpha) ]##

% Axes (Axes)

18##[Width:=2,Color:=0,Arrows:=1,FillStyle:=0]##

1#Axes#[0+i*(0),1+i*(1),0+i*(0)]#0#0##

% Origine (Point(s))

4#Origine#[0  ]##
1. Je n'arrive pas à créer des fichiers.pgf, mais je peux voir l'animation !

2. Amélioration du code (fenêtre, trace du point, affichage des "deux"animations dans deux fenêtres parallèles......)
Very Happy
Merci

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Dim 17 Fév - 13:51

Bonjour F(rançois?),

Pour moi ton code ne pose de problèmes, sans le modifier j'obtiens ceci en flash:



Quand tu cliques sur le bouton Enregistrer, tes 50 frames sont enregistrées au format pgf dans le dossier $HOME/.TeXgraph, est-ce bien le cas? Attention: quand tu fermes TeXgraph ils sont effacés.
Puis une fenêtre s'ouvre te demandant le nom du fichier pdf qui va être créé, on lui donne un nom (et son chemin) mais sans extension, C'est ok?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Dim 17 Fév - 14:36

Salut,
Je ne trouve aucune trace de ces 50 fichiers au format pgf, le seul fichier obtenu est essai.teg après fermeture de TeXgraph.
Quand je clicke sur le bouton enregistrer, TeXgraph me dit que 50 frames au format pgf vont être enregistrées dans le répertoire ·home/fab/.TeXgraph.
Puis, à la question " voulez-vous continuer ? ", je clicke sur ok et le message d'erreur apparaît (cf image de mon précédent message).
Quand je parle d'améliorer le code, c'est pour avoir :
- la figure géométrique et la trajectoire du point dans deux fenêtres en parallèle (à la façon de feu géoplan Very Happy ) ;
- la trace du point S pour " voir " la parabole tracée ;
- une animation moins " rapide " ;
- les étiquettes "x" et "y", le point origine O que je n'arrive pas à voir, même en créant les labels. (problème de fenêtre ?)
Questions :
1) Quel est le format qui permet d'avoir le meilleur rendu des graphiques à la sortie de l'imprimante ? (eps ?)
2) Dans ta macro MakeFile(), %1* indique le pas ?
Merci.
Fabrice Couvreur.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Dim 17 Fév - 15:37

F.Couvreur a écrit:
Quand je clicke sur le bouton enregistrer, TeXgraph me dit que 50 frames au format pgf vont être enregistrées dans le répertoire ·home/fab/.TeXgraph.

Ce répertoire existe-t'il? Si oui as-tu les bons droits sur ce répertoire?


Quand je parle d'améliorer le code, c'est pour avoir :
- la figure géométrique et la trajectoire du point dans deux fenêtres en parallèle (à la façon de feu géoplan Very Happy ) ;

Il faut déjà régler le problème des exports pgf. Je suppose que l'aperçu ne fonctionne pas non plus, ni l'export pdf compilé, ni eps compilé?


- la trace du point S pour " voir " la parabole tracée ;

ça ce n'est pas difficile, on verra quand le pgf sera réglé.


- une animation moins " rapide " ;

tu allonges le tempo!


- les étiquettes "x" et "y", le point origine O que je n'arrive pas à voir, même en créant les labels. (problème de fenêtre ?)

Regarde bien ton élément Axes, dans l'option Label origine tu as coché "none"!
Pour ajouter des labels sur les axes il y a la macro LabelAxes, dans un élément Utilisateur

Code:

[LabelAxe(x,9.5,"$x$",2),
 LabelAxe(y,11.5*i,"$y$",1)]


Questions :
1) Quel est le format qui permet d'avoir le meilleur rendu des graphiques à la sortie de l'imprimante ? (eps ?)

eps/pdf


2) Dans ta macro MakeFile(), %1* indique le pas ?
Ce ne serait pas plutôt MakeFrame? Si oui c'est le numéro de la frame (ou de l'image si tu préfères).


Dernière édition par le Dim 17 Fév - 22:58, édité 1 fois

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Dim 17 Fév - 21:17

Une proposition pour avoir les deux fenêtres l'une au-dessus l'autre:



Et le fichier source:

Code:

% TeXgraph version 1.93
% Fenetre Xmin Xmax Ymin Ymax Xscale Yscale
100#0#9.5#-12.5#10.5#0.76086956521739#0.45652173913043##
% Marges gauche droite haut bas cadre gestion_couleur comptgraph
101#1#0.5#0.5#1#0#1#40##
% Affectation des Variables theta et phi
18##[theta:=0.5236, phi:=1.0472, OriginalCoord(1)]##
18##InputMac("Animation.mac")##
% Déclaration des Variables Globales
15#alpha#0##
15#courbe#0##
% Déclaration des Macros
16#MakeFrame#[{code pour dessiner la frame n° %1}
 Inc(alpha,4/25), ReCalc()
]
##
16#OnBeginAnim#[{exécutée au lancement de l'animation}
]##
16#OnEndAnim#[{exécutée à la fin de l'animation}
]##
16#Initialiser#[{valeurs par défaut de vos paramÚtres}
  alpha:=0, courbe:=1/0, ReCalc()
]
##
16#Tempo#250##
16#NbFrames#50
##
16#Nom#"/home/pfradin/tmp/FCouvreur"##
16#PdfReader#"xpdf"##
% Déclaration des Eléments graphiques
% fenetre1 (Utilisateur)
18##[tMax:=10.1935]##
14#fenetre1#[$coinSup:=Xmin+i*Ymax, $coinInf:=Xmax+i*Ymin,
 Fenetre(Ymax*i-0.35,Xmax-0.45*i),
 LabelSize:=footnotesize,
 Arrows:=2,
 LineStyle:=noline,axes(0,1+i,1+i),
 LineStyle:=solid, Ligne([i*Ymax,0,Xmax],0),
 Arrows:=0,
 LabelAxe(x,9.5,"$x$",2),
 LabelAxe(y,10.5*i,"$y$",1),
 Ligne([0,8,8+10*i],1),
 FillStyle:=full, FillColor:=red, Color:=red,
 $m:=rect(8,alpha,alpha*(1+i*5/4)),
 Point(m), Color:=black,Ligne(m,1),
 Fenetre(coinSup,coinInf)
 ]
#-1##
% fenetre2 (Utilisateur)
18##[tMax:=10]##
14#fenetre2#[$coinSup:=Xmin+i*Ymax, $coinInf:=Xmax+i*Ymin,
 Fenetre(-2*i-0.35,Xmax +i*Ymin-0.45*i),
 SetMatrix([-12.5*i,1,i]),
 LabelSize:=footnotesize,
 Arrows:=2,LineStyle:=noline,axes(0,1+i,1+i),LineStyle:=solid,
 Ligne([i*10.5,0,Xmax],0),
 Arrows:=0,
 LabelAxe(x,9.5,"$x$",2),
 LabelAxe(y,10.5*i,"$y$",1),
 $S':=abs(alpha)+i*0.5*abs(alpha*5/4)*abs(8-alpha),
 Color:=red, Width:=8,
 Insert(courbe,S'), Ligne(courbe,0), Point(S'),
 Fenetre(coinSup,coinInf)
 ]#-1##

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Lun 18 Fév - 14:07

Bonjour Patrick,
Pour l'amélioration du code, c'est exactement ce que je souhaitais !
Ce ne serait pas plutôt MakeFrame? Si oui c'est le numéro de la frame (ou de l'image si tu préfères).
Embarassed
Le numéro de la frame correspond-t-il à une position du point M sur le segment [BA] ?
alpha :=%1*4/25 veut-il dire que le point M se déplace tous les 4/25 cm sur le segment [BA] ? (50 frames*(4/25 cm)=8cm (longueur du segment [BA]).
Ce répertoire existe-t'il? Si oui as-tu les bons droits sur ce répertoire?
Je suis sous linux depuis à peine un mois (ubuntu 7.10), il y a peut-être quelque chose qui m'échappe !
Je joins ma procédure d'installation de TeXgraph :

fab@fab-desktop:~$ mkdir TeXgraph
fab@fab-desktop:~$ cd TeXgraph
fab@fab-desktop:~/TeXgraph$ tar xzf TeXgraph1.93.tar.gz
fab@fab-desktop:~/TeXgraph$ cd TeXgraph1.93
fab@fab-desktop:~/TeXgraph/TeXgraph1.93$ sudo su
root@fab-desktop:/home/fab/TeXgraph/TeXgraph1.93# ./install.sh
Vous �tes connect� en tant que root,
l'installation sera faite dans /usr/local/share/TeXgraph.
Continuer (y/n)?:y
installation du package texgraph.sty dans /usr/local/share/texmf/tex/latex/TeXgraph...
mise � jour de la base de donn�es TeX...
texhash: Updating /usr/local/share/texmf/ls-R...
texhash: Updating /var/lib/texmf/ls-R-TEXMFMAIN...
texhash: Updating /var/lib/texmf/ls-R-TEXLIVE...
texhash: Updating /var/lib/texmf/ls-R...
texhash: Done.
installation des ex�cutables et Cie dans /usr/local/share/TeXgraph...
g�n�ration des scripts dans /usr/local/bin...
Done
root@fab-desktop:/home/fab/TeXgraph/TeXgraph1.93#

Quand je clicke sur le bouton enregistrer, je n'ai plus de messages
d'erreur, mais je ne trouve pas les fichiers frames.pgf,essai.pdf et essai.swf !
Au secours !!!!

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Lun 18 Fév - 14:14

Salut Fabrice,

Procédons par ordre, il me semble que ton installation s'est bien déroulée. Je vais te poser quelques questions simples, pas à pas, il faudra y répondre:

1) As-tu le répertoire .TeXgraph dans ton home? Attention c'est un répertoire caché! Il faut demandé à ton gestionnaire de fichiers d'afficher les dossiers cachés.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Lun 18 Fév - 14:37

Il y a bien un fichier caché .TeXgraph où se trouve 5 fichiers ( 4 préinstallés et 1 essai.html).
Tout cela je l'avais déjà avant que je sollicite ton aide (le fichier essai.html étant vide !)

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Lun 18 Fév - 15:10

Très bien,

Bon maintenant tu lances TeXgraph, tu dessines des axes par exemple (Ctrl+A), puis tu demandes un aperçu en cliquant le bouton en forme d'oeil.

1) Est-ce que xpdf s'ouvre avec l'aperçu?

Puis, sans fermer TeXgraph, regardes dans le dossier .TeXgraph, il doit y avoir: file.pgf, Apercu.pdf et Apercu.log.

2) As-tu bien ces fichiers?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Lun 18 Fév - 23:41

Bonsoir,
Désolé d'avoir interrompu le fil, mais j'ai dû m'absenter.
puis tu demandes un aperçu en cliquant le bouton en forme d'oeil.

1) Est-ce que xpdf s'ouvre avec l'aperçu?
Message d'erreur : "Création du fichier impossible ".
Aucun fichier dans le dossier .TeXgraph !

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 0:06

C'est fou cette histoire! C'est pourtant TeXgraph qui a créé ce dossier et mis les quelques fichiers que tu as dedans!

Lance TeXgraph, crée des axes par exemple, dans la ligne de commande en bas de la fenêtre tape la commande: Export(pfg, "/home/fab/test.pgf")

Est-ce que le fichier test.pgf est créé dans /home/fab?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 0:16

Message : " warning ! Résultat = Nil "
Aucun fichier test.pgf dans /home/fab

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 0:26

Lance TeXgraph, créé des axes et enregistre le fichier dans /home/fab/ sous le nom test (ne pas mettre l'extension teg). As-tu le fichier test.teg dans /home/fab/?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 0:33

Il y a un bien un fichier test.teg.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 0:36

Bon, donc à priori ce n'est pas un problème d'écriture.

Toujours avec les axes dans TeXgraph, si tu exportes par le menu: Fichier/Exporter en pgf, toujours dans /home/fab/, as-tu le fichier test.pgf?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 0:40

Il y a bien un fichier test.pgf.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 0:44

Ok, bon si tu exportes de nouveau ton graphique (Fichier/Exporter en pgf) mais cette fois-ci dans le dossier /home/fab/.TeXgraph en gardant le même nom. C'est toujours ok?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 0:53

" Access denied. Press ok to ignore and risk data corruption . Press Cancel to kill the program. "

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 0:59

Tiens tiens! Accès refusé! Peux-tu regarder quels sont tes droits sur le dossier caché .TeXgraph et à qui il appartient? Avec ton gestionnaire de fichiers, un clic droit sur le dossier et option Propriétés (enfin si c'est comme sous Mandriva!)

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 1:02

Propriétaire : root

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 1:07

Voilà le problème! aurais-tu exécuté TeXgraph en root? Peu importe.

1) Ferme TeXgraph,

2) connecte-toi en root et supprime ce dossier .TeXgraph

3) reviens en utilisateur fab et relance TeXgraph

4) tu dois avoir maintenant un nouveau dossier .TeXgraph et qui est à toi celui-là! Tu confirmes?


Dernière édition par le Mar 19 Fév - 1:25, édité 1 fois

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 1:19

Exact, il y a bien un fichier .TeXgraph dont le propriétaire est fab-Fabrice Couvreur et contenat le fichier test.pgf Very Happy

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 1:22

Donc en principe l'aperçu doit maintenant fonctionner! Et tu vas pouvoir enregistrer ton animation! Tu confirmes pour l'aperçu?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Animation

Message  F.Couvreur le Mar 19 Fév - 1:50

un fichier .TeXgraph
: dossier .TeXgraph
contenat
: contenant Embarassed
L'aperçu fonctionne, les 50 frames.pgf sont bien dans le dossier .TeXgraph et le fichier html dans le répertoire /home/fab (que je n'arrive pas à lire !).
Voilà le problème! aurais-tu exécuté TeXgraph en root?
Oui, car j'ai lancé TeXgraph à la suite de son installation (cf message avec procédure d'installation).
Je te suis très reconnaissant pour ton aide et admiratif de ton travail.
Merci.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  P.Fradin le Mar 19 Fév - 1:57

F.Couvreur a écrit:
L'aperçu fonctionne, les 50 frames.pgf sont bien dans le dossier .TeXgraph et le fichier html dans le répertoire /home/fab (que je n'arrive pas à lire !).

Si tu as installé swftools, tu dois avoir aussi un fichier swf non? En principe firefox sait le lire.


Oui, car j'ai lancé TeXgraph à la suite de son installation (cf message avec procédure d'installation).
Voilà pourquoi! Il faudra que je signale ce risque dans le fichier LisezMoi.

Je te suis très reconnaissant pour ton aide et admiratif de ton travail.
Merci.

Merci du compliment!

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: [Résolu] Animation

Message  Contenu sponsorisé Aujourd'hui à 2:08


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 3 1, 2, 3  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum