Problème pour un label

Voir le sujet précédent Voir le sujet suivant Aller en bas

Problème pour un label

Message  F.Couvreur le Mar 9 Déc - 22:00

Bonsoir Patrick,
Je ne parviens pas, après compilation, à obtenir le nom d'une courbe avec la fonte \mathscr. Je suis allé dans le fichier CompileEps.tex pour y rajouter le package mathrsfs, puis j'ai fait un texhash en root.
Mais rien n'y fait !
Code:
[Fenetre(-3+4*i, 3-2*i, 1.5+1.5*i),
 Width:=4,Color:=lightgray,Grille(0+0*i,0.5+0.5*i),
 Width:=6, Color:=darkgray, Grille(0+0*i,1+1*i),
 xyticks:=0.1, xylabelpos:=none,
 Color:=black, Arrows:=1, Width:=8, Axes(0,1+1*i,0),
 LabelAxe(x,1,"$1$"), LabelAxe(y,i,"$1$",2),
 Label(2.9-0.2*i,"$x$",-0.1+3.8*i,"$y$",-0.1-0.2*i,"0",2.2+1.8*i,"$\mathscr{C}$"),
 tMin:=-2,tMax:=2,NewMac("f","x^3-3*x+1",x), LineStyle:=solid,Arrows:=0,
 Width:=8,Courbe(t+i*f(t))]
Merci.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème pour un label

Message  P.Fradin le Mar 9 Déc - 23:28

Bonsoir Fabrice,

Si tu as modifié le fichier CompileEps.tex qui est dans le répertoire d'installation de TeXgraph, alors il faut ensuite que tu supprimes celui qui est dans le dossier (caché) .TeXgraph, puis que tu relances TeXgraph.

PS: un texhash est inutile puisque tu n'ajoutes pas de package à ta distribution en réalité.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: Problème pour un label

Message  F.Couvreur le Mar 9 Déc - 23:56

Re,
Je viens de faire ce que tu m'as conseillé, mais cela ne fonctionne pas.
J'ai relancé TeXgraph à partir de la console à l'aide de la commande startTeXgraph.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème pour un label

Message  P.Fradin le Mer 10 Déc - 0:09

Bizarre,

Je viens de tester et ici ça marche! Je récapitule: dans le dossier caché ~/.TeXgraph (ne pas oublier le point devant!) tu dois avoir un fichier CompileEps.tex, c'est lui qu'il faut modifier.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: Problème pour un label

Message  F.Couvreur le Mer 10 Déc - 0:27

Re,
tu supprimes celui qui est dans le dossier (caché) .TeXgraph
dans le dossier caché ~/.TeXgraph (ne pas oublier le point devant!) tu dois avoir un fichier CompileEps.tex, c'est lui qu'il faut modifier.
Au départ, j'ai modifié le fichier qui se trouve dans le répertoire d'installation, et j'ai supprimé celui qui se trouvait dans le dossier caché.
Je viens maintenant de modifier celui qui se trouvait dans le dossier caché, et cela fonctionne !
Merci.
@+

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème pour un label

Message  P.Fradin le Mer 10 Déc - 0:35

Normalement, si tu supprimes le CompileEps.tex celui qui est dans le répertoire caché, le prochain lancement de TeXgraph recopie le fichier CompileEps.tex dans le dossier caché.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: Problème pour un label

Message  F.Couvreur le Mer 10 Déc - 13:27

Bonjour Patrick,
Tu vas peut-être me trouver "pinailleur" , mais j'ai l'impression qu'autours des extrema, la courbe est tracée avec des segments de droite.
Faut-il augmenter le nombre de points pour corriger ce petit problème, s'il existe vraiment ?
Merci.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème pour un label

Message  P.Fradin le Mer 10 Déc - 13:44

Bonjour Fabrice,

Effectivement une courbe est tracée avec des segments de droites, tu peux augmenter le nombre de points. Ceci dit avec ton exemple du premier post, sans changer le nombre de points par défaut, je dois faire un zoom à 1000% pour vraiment voir les segments!

D'une manière générale une courbe n'est pas un objet vectoriel (contrairement aux courbes de Bézier), si on veut qu'elle le devienne, alors il faut faire un lissage avec des splines, par exemple:

Code:

[Fenetre(-3+4*i, 3-2*i, 1.5+1.5*i),
 Width:=4,Color:=lightgray,Grille(0+0*i,0.5+0.5*i),
 Width:=6, Color:=darkgray, Grille(0+0*i,1+1*i),
 xyticks:=0.1, xylabelpos:=none,
 Color:=black, Arrows:=1, Width:=8, Axes(0,1+1*i,0),
 LabelAxe(x,1,"$1$"), LabelAxe(y,i,"$1$",2),
 Label(2.9-0.2*i,"$x$",-0.1+3.8*i,"$y$",-0.1-0.2*i,"0",2.2+1.8*i,"$\mathscr{C}$"),
 tMin:=-2,tMax:=2,NewMac("f","x^3-3*x+1",x), LineStyle:=solid,Arrows:=0,
 Width:=8, NbPoints:=25, L:=Get(Courbe(t+i*f(t)),0), Spline(0,L,0)
]

Mais est-ce vraiment beaucoup mieux?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: Problème pour un label

Message  F.Couvreur le Mer 10 Déc - 23:37

Bonsoir Patrick,
Mais est-ce vraiment beaucoup mieux?
Non. J'ai fixé la valeur de NbPoints à 100, et je trouve que c'est mieux Very Happy
Merci.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème pour un label

Message  P.Fradin le Mer 10 Déc - 23:41

F.Couvreur a écrit:Bonsoir Patrick,
Mais est-ce vraiment beaucoup mieux?
Non. J'ai fixé la valeur de NbPoints à 100, et je trouve que c'est mieux Very Happy
Merci.

Avec la commande Spline ou la commande Courbe?

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: Problème pour un label

Message  F.Couvreur le Jeu 11 Déc - 0:07

Re,
Avec la commande Courbe.

F.Couvreur

Nombre de messages : 137
Age : 53
Date d'inscription : 10/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème pour un label

Message  P.Fradin le Jeu 11 Déc - 0:11

F.Couvreur a écrit:Re,
Avec la commande Courbe.

Re,

Je pense aussi que pour les courbes c'est mieux ainsi en général. Mais je reconnais que lorqu'on veut une image pdf susceptible d'être grossie pas mal de fois (jusqu'au format A4 par exemple), avoir la courbe en vectoriel est appréciable plutôt des segments de droites même s'ils sont tout petits.

A+

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: Problème pour un label

Message  Contenu sponsorisé Aujourd'hui à 11:53


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum