Couleurs et compilation (pb xcolor ?)

Voir le sujet précédent Voir le sujet suivant Aller en bas

Couleurs et compilation (pb xcolor ?)

Message  LPARISE le Sam 6 Sep - 1:31

Bonjour et félicitations pour votre travail exceptionnel !

J'ai un problème avec l'export en EPS compilé, uniquement lorsque ma figure contient de
la couleur ! Je fais tourner TeXgraph sous linux Slackware fournie par défaut avec tetex.

Voici le type de message que j'obtiens à la compilation :

(/usr/share/texmf/tex/latex/lm/t1lmr.fd) (./file.pst
! Package xcolor Error: Undefined color `[rgb]{1,0.3137,0.7137}'.
See the xcolor package documentation for explanation.

C'est curieux car j'ai vérifié que le package xcolor de LaTeX est bien installé. J'ai le même problème losque j'exporte
en pst puis compile un fichier latex incluant le fichier pst.

La ligne
\psset{linecolor={black},linewidth=0.2pt,fillstyle=solid,fillcolor=[rgb]{1,0.3137,0.7137}}
semble ne pas être interprétée à cause de [rgb]{1,0.3137,0.7137}

Résultat, tous les fichiers eps obtenus sont en noir et blanc. Avez-vous une explication de ce phénomène ?
Je ne sais pas trop dans quelle direction chercher (pb de version de xcolor ? j'ai la dernière Slackware disponible ...).

D'avance merci,
L.PARISE

LPARISE

Nombre de messages : 2
Age : 43
Date d'inscription : 05/09/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Couleurs et compilation (pb xcolor ?)

Message  P.Fradin le Sam 6 Sep - 10:13

Bonjour,

Le problème n'est pas lié à l'OS, c'est un problème de version de pstricks qui n'est pas à jour. Mettez ce package à jour et tout devrait rentrer dans l'ordre.

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: Couleurs et compilation (pb xcolor ?)

Message  LPARISE le Sam 6 Sep - 23:55

Merci pour votre réponse. C'est en cherchant dans cette voie que j'ai trouvé la solution à mon problème.

C'est le package xcolor qui devait être mis à jour dans la distribution teTeX. Je viens de découvrir teTeX n'est plus maintenue
depuis 2005 ... et n'est donc plus à jour. Des discussions portent actuellement sur le remplacement de cette distribution de TeX
dans Slackware par TeXLive contenue par exemple dans Ubuntu et Gentoo ...

En fait, tous les utilisateurs de Slackware devraient avoir le même problème que moi, et ce problème est dû actuellement
à cette distribution de Linux.

Cordialement,
L.PARISE

LPARISE

Nombre de messages : 2
Age : 43
Date d'inscription : 05/09/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Couleurs et compilation (pb xcolor ?)

Message  P.Fradin le Dim 7 Sep - 0:03

Bonsoir,

Oui c'est un problème quand la distribution Linux utilisée propose par défaut une distribution TeX qui n'est plus maintenue! C'est ce qui m'a poussé (en partie) à changer, et je suis aujourd'hui sous Ubuntu.

Ceci dit on peut mettre à jour à la main les packages, ce n'est pas un problème. Le plus embêtant c'est quand les binaires seront vraiment obsolètes!

_________________
P.Fradin

P.Fradin
Admin

Nombre de messages : 1133
Age : 55
Date d'inscription : 19/01/2008

Voir le profil de l'utilisateur http://texgraph.tuxfamily.org/

Revenir en haut Aller en bas

Re: Couleurs et compilation (pb xcolor ?)

Message  Contenu sponsorisé Aujourd'hui à 11:51


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum